Resolved
The issue is resolved and the Prelude dashboard is back to working properly.
Identified
The Prelude dashboard might be facing some latencies and delay at displaying actual data.
Those latencies are related to a third party provider issue.
The team is currently investigating