Resolved
AWS solved the underlying issue from their side.
Identified
We identified the root cause to be an issue on the AWS Lambda platform. AWS confirmed to us that they are currently facing issues.
We are currently working with AWS to resolve the elevated errors.
Investigating
We are observing degraded performance across our APIs with an elevated rate of errors on a small percentage of incoming requests.